Vulnerability · Published Jan 1, 2023 · Assigned by VulDB
CVE-2021-4297trampgeek jobe Restapi.php runs_post Privilege Escalation
Medium 5.5
In plain English
A medium-severity incorrect default permissions in jobe from trampgeek. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.
Affected products (as reported)
Weakness: CWE-276 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
References
- https://vuldb.com/?id.217174 vdb-entry, technical-description
- https://vuldb.com/?ctiid.217174 signature, permissions-required
- https://github.com/trampgeek/jobe/issues/46 issue-tracking
- https://github.com/trampgeek/jobe/commit/694da5013dbecc8d30dd83e2a83e78faadf93771 patch