Vulnerability · Published Dec 27, 2022 · Assigned by VulDB
CVE-2021-4291OpenMRS Admin UI Module location.gsp cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in Admin UI Module from OpenMRS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities).
Official description
A vulnerability was found in OpenMRS Admin UI Module up to 1.5.x. It has been declared as problematic. This vulnerability affects unknown code of the file omod/src/main/webapp/pages/metadata/locations/location.gsp. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216916.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMRS | Admin UI Module | 1.01.11.21.31.41.5 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.216916 vdb-entry
- https://vuldb.com/?ctiid.216916 signature, permissions-required
- https://github.com/openmrs/openmrs-module-adminui/pull/61 issue-tracking
- https://github.com/openmrs/openmrs-module-adminui/commit/a7eefb5f69f6c50a3bffcb138bb8ea57cb41a9b6 patch
- https://github.com/openmrs/openmrs-module-adminui/releases/tag/1.6.0 patch