Vulnerability · Published Dec 27, 2022 · Assigned by VulDB
CVE-2021-4288OpenMRS openmrs-module-referenceapplication userApp.gsp cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in openmrs-module-referenceapplication from OpenMRS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities).
Official description
A vulnerability was found in OpenMRS openmrs-module-referenceapplication up to 2.11.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/userApp.gsp. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.12.0 is able to address this issue. The name of the patch is 35f81901a4cb925747a9615b8706f5079d2196a1. It is recommended to upgrade the affected component. The identifier VDB-216881 was assigned to this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMRS | openmrs-module-referenceapplication | 2.02.12.22.32.42.52.62.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.216881 vdb-entry
- https://vuldb.com/?ctiid.216881 signature, permissions-required
- https://github.com/openmrs/openmrs-module-referenceapplication/pull/92 issue-tracking
- https://github.com/openmrs/openmrs-module-referenceapplication/commit/35f81901a4cb925747a9615b8706f5079d2196a1 patch
- https://github.com/openmrs/openmrs-module-referenceapplication/releases/tag/referenceapplication-2.12.0 patch