Vulnerability · Published Dec 19, 2022 · Assigned by VulDB
CVE-2021-4261pacman-canvas db-handler.php addHighscore sql injection
Medium 6.3
In plain English
A medium-severity security flaw in pacman-canvas from unspecified. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 51% of all known vulnerabilities).
Official description
A vulnerability classified as critical has been found in pacman-canvas up to 1.0.5. Affected is the function addHighscore of the file data/db-handler.php. The manipulation leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.6 is able to address this issue. The name of the patch is 29522c90ca1cebfce6453a5af5a45281d99b0646. It is recommended to upgrade the affected component. VDB-216270 is the identifier assigned to this vulnerability.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| unspecified | pacman-canvas | 1.0.01.0.11.0.21.0.31.0.41.0.5 |
Weakness: CWE-707 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L