Vulnerability · Published Aug 24, 2022 · Assigned by redhat

CVE-2021-4178

Medium 6.7

In plain English

A medium-severity unsafe deserialization in kubernetes-client. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.7Medium
Exploit odds (30 days)0.3%top 72.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenio.fabric8:kubernetes-client5.0.3GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.1.2GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.3.2GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.7.4GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.8.1GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.10.2GHSA-98g7-rxmf-rrxm
Mavenio.fabric8:kubernetes-client5.11.2GHSA-98g7-rxmf-rrxm

Affected products (as reported)

VendorProductVersions
n/a kubernetes-client Affects 5.x versions, Fixed in kubernetes-client v5.0.3 and above.

Weakness: CWE-502

References