Vulnerability · Published Sep 17, 2021 · Assigned by apache

CVE-2021-41303Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass

Critical 9.8

In plain English

A critical-severity improper authentication in Apache Shiro from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 76.1% (higher than 99.5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)76.1%top 0.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass. Users should update to Apache Shiro 1.8.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12shirono fix listedDEBIAN-CVE-2021-41303
Debian:13shirono fix listedDEBIAN-CVE-2021-41303
Debian:14shirono fix listedDEBIAN-CVE-2021-41303
Mavenorg.apache.shiro:shiro-core1.8.0GHSA-f6jp-j6w3-w9hm

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Shiro Apache Shiro – before 1.8.0

Weakness: CWE-287

References