Vulnerability · Published Feb 17, 2022 · Assigned by canonical

CVE-2021-4120snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths

High 8.2

In plain English

A high-severity improper input validation in snapd from Canonical Ltd.. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.4%top 61.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

snapd 2.54.2 fails to perform sufficient validation of snap content interface and layout paths, resulting in the ability for snaps to inject arbitrary AppArmor policy rules via malformed content interface and layout declarations and hence escape strict snap confinement. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12snapd2.54.3-1DEBIAN-CVE-2021-4120
Debian:13snapd2.54.3-1DEBIAN-CVE-2021-4120
Debian:14snapd2.54.3-1DEBIAN-CVE-2021-4120

Affected products (as reported)

VendorProductVersions
Canonical Ltd. snapd unspecified – through 2.54.2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References