Vulnerability · Published Oct 28, 2021 · Assigned by GitHub_M

CVE-2021-41194Improper Access Control in jupyterhub-firstuseauthenticator

Critical 9.1

In plain English

A critical-severity improper access control in firstuseauthenticator from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)1.4%top 28.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

FirstUseAuthenticator is a JupyterHub authenticator that helps new users set their password on their first login to JupyterHub. When JupyterHub is used with FirstUseAuthenticator, a vulnerability in versions prior to 1.0.0 allows unauthorized access to any user's account if `create_users=True` and the username is known or guessed. One may upgrade to version 1.0.0 or apply a patch manually to mitigate the vulnerability. For those who cannot upgrade, there is no complete workaround, but a partial mitigation exists. One can disable user creation with `c.FirstUseAuthenticator.create_users = False`, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until a patch or upgrade occurs.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIjupyterhub-firstuseauthenticator1.0.0GHSA-5xvc-vgmp-jgc3
PyPIjupyterhub-firstuseauthenticator1.0.0PYSEC-2021-384

Affected products (as reported)

VendorProductVersions
jupyterhub firstuseauthenticator < 1.0.0

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References