Vulnerability · Published Mar 1, 2022 · Assigned by GitHub_M
CVE-2021-41193Use of Externally-Controlled Format String in wire-avs
Critical 9.8
In plain English
A critical-severity security flaw in wire-avs from wireapp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
wire-avs is the audio visual signaling (AVS) component of Wire, an open-source messenger. A remote format string vulnerability in versions prior to 7.1.12 allows an attacker to cause a denial of service or possibly execute arbitrary code. The issue has been fixed in wire-avs 7.1.12. There are currently no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.wire:avs | 7.1.12 | GHSA-2j6v-xpf3-xvrv |
Affected products (as reported)
Weakness: CWE-134 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H