Vulnerability · Published Oct 26, 2021 · Assigned by GitHub_M

CVE-2021-41188Authenticated Stored XSS in Administration

Medium 5.7

In plain English

A medium-severity cross-site scripting in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.7Medium
Exploit odds (30 days)0.8%top 44.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/shopware5.7.6GHSA-4p3x-8qw9-24w9

Affected products (as reported)

VendorProductVersions
shopware shopware < 5.7.6

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N

References