Vulnerability · Published Oct 26, 2021 · Assigned by GitHub_M

CVE-2021-41184XSS in the `of` option of the `.position()` util

Medium 6.5

In plain English

A medium-severity cross-site scripting in jquery-ui from jquery. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 40.8% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)40.8%top 1.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of` option is now treated as a CSS selector. A workaround is to not accept the value of the `of` option from untrusted sources.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41184
Debian:13jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41184
Debian:14jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41184
Mavenorg.webjars.npm:jquery-ui1.13.0GHSA-gpqq-952q-5327
NuGetjquery.ui.combined1.13.0GHSA-gpqq-952q-5327
RubyGemsjquery-ui-rails7.0.0GHSA-gpqq-952q-5327
npmjquery-ui1.13.0GHSA-gpqq-952q-5327

Affected products (as reported)

VendorProductVersions
jquery jquery-ui < 1.13.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References