Vulnerability · Published Oct 26, 2021 · Assigned by GitHub_M

CVE-2021-41183XSS in `*Text` options of the Datepicker widget

Medium 6.5

In plain English

A medium-severity cross-site scripting in jquery-ui from jquery. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.5% (higher than 95% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)8.5%top 4.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. The values passed to various `*Text` options are now always treated as pure text, not HTML. A workaround is to not accept the value of the `*Text` options from untrusted sources.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20drupal77.86-r0ALPINE-CVE-2021-41183
Debian:12jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41183
Debian:13jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41183
Debian:14jqueryui1.13.0+dfsg-1DEBIAN-CVE-2021-41183
Mavenorg.webjars.npm:jquery-ui1.13.0GHSA-j7qv-pgf6-hvh4
NuGetjquery.ui.combined1.13.0GHSA-j7qv-pgf6-hvh4
RubyGemsjquery-ui-rails7.0.0GHSA-j7qv-pgf6-hvh4
npmjquery-ui1.13.0GHSA-j7qv-pgf6-hvh4

Affected products (as reported)

VendorProductVersions
jquery jquery-ui < 1.13.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References