Vulnerability · Published Oct 25, 2021 · Assigned by GitHub_M
CVE-2021-41179Two-Factor Authentication not enforced for pages marked as public
Medium 6.5
In plain English
A medium-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities).
Official description
Nextcloud is an open-source, self-hosted productivity platform. Prior to Nextcloud Server versions 20.0.13, 21.0.5, and 22.2.0, the Two-Factor Authentication wasn't enforced for pages marked as public. Any page marked as `@PublicPage` could thus be accessed with a valid user session that isn't authenticated. This particularly affects the Nextcloud Talk application, as this could be leveraged to gain access to any private chat channel without going through the Two-Factor flow. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 20.0.13>= 21.0.0, < 21.0.5< 22.2.0 |
Weakness: CWE-304 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7hvh-rc6f-px23 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/28725 x_refsource_MISC
- https://hackerone.com/reports/1322865 x_refsource_MISC