Vulnerability · Published Oct 25, 2021 · Assigned by GitHub_M
CVE-2021-41177Rate-limits not working on instances without configured memory cache backend
High 8.1
In plain English
A high-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities).
Official description
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 20.0.13>= 21.0.0, < 21.0.5< 22.2.0 |
Weakness: CWE-799 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-fj39-4qx4-m3f2 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/28728 x_refsource_MISC
- https://hackerone.com/reports/1265709 x_refsource_MISC
- GLSA-202208-17 vendor-advisory, x_refsource_GENTOO