Vulnerability · Published Oct 26, 2021 · Assigned by GitHub_M

CVE-2021-41175Stored XSS in Client Groups Management (Authenticated)

High 7.3

In plain English

A high-severity cross-site scripting in AdminLTE from pi-hole. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities).

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.9%top 40.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Pi-hole's Web interface (based on AdminLTE) provides a central location to manage one's Pi-hole and review the statistics generated by FTLDNS. Prior to version 5.8, cross-site scripting is possible when adding a client via the groups-clients management page. This issue was patched in version 5.8.

Affected products (as reported)

VendorProductVersions
pi-hole AdminLTE < 5.8

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

References