Vulnerability · Published Nov 17, 2021 · Assigned by GitHub_M
CVE-2021-41165HTML comments vulnerability allowing to execute JavaScript code
High 8.2
In plain English
A high-severity cross-site scripting in ckeditor4 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ckeditor | 4.19.0+dfsg-1 | DEBIAN-CVE-2021-41165 |
| Debian:12 | ckeditor3 | no fix listed | DEBIAN-CVE-2021-41165 |
| Packagist | ckeditor/ckeditor | 4.17.0 | GHSA-7h26-63m7-qhf2 |
| Ubuntu:22.04:LTS | ckeditor3 | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:24.04:LTS | ckeditor3 | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:22.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:24.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:25.10 | ldap-account-manager | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:26.04:LTS | ldap-account-manager | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:22.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:24.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:25.10 | request-tracker4 | no fix listed | UBUNTU-CVE-2021-41165 |
| Ubuntu:26.04:LTS | request-tracker4 | no fix listed | UBUNTU-CVE-2021-41165 |
| npm | ckeditor4 | 4.17.0 | GHSA-7h26-63m7-qhf2 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
References
- https://github.com/ckeditor/ckeditor4/blob/major/CHANGES.md#ckeditor-417 x_refsource_MISC
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7h26-63m7-qhf2 x_refsource_CONFIRM
- https://www.oracle.com/security-alerts/cpujan2022.html x_refsource_MISC
- https://www.drupal.org/sa-core-2021-011 x_refsource_CONFIRM
- https://www.oracle.com/security-alerts/cpuapr2022.html x_refsource_MISC
- https://www.oracle.com/security-alerts/cpujul2022.html x_refsource_MISC