Vulnerability · Published Oct 21, 2021 · Assigned by GitHub_M

CVE-2021-41160Improper region checks in FreeRDP allow out of bound write to memory

Medium 5.3

In plain English

A medium-severity out-of-bounds write in FreeRDP from FreeRDP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.7%top 23.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

FreeRDP is a free implementation of the Remote Desktop Protocol (RDP), released under the Apache license. In affected versions a malicious server might trigger out of bound writes in a connected client. Connections using GDI or SurfaceCommands to send graphics updates to the client might send `0` width/height or out of bound rectangles to trigger out of bound writes. With `0` width or heigth the memory allocation will be `0` but the missing bounds checks allow writing to the pointer at this (not allocated) region. This issue has been patched in FreeRDP 2.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8freerdp2:2.2.0-7.el8_5ALSA-2021:4622
AlmaLinux:8freerdp-devel2:2.2.0-7.el8_5ALSA-2021:4622
AlmaLinux:8freerdp-libs2:2.2.0-7.el8_5ALSA-2021:4622
AlmaLinux:8libwinpr2:2.2.0-7.el8_5ALSA-2021:4622
AlmaLinux:8libwinpr-devel2:2.2.0-7.el8_5ALSA-2021:4622
Alpine:v3.20freerdp2.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.21freerdp2.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.22freerdp2.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.23freerdp2.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.24freerdp2.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.22freerdp22.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.23freerdp22.4.1-r0ALPINE-CVE-2021-41160
Alpine:v3.24freerdp22.4.1-r0ALPINE-CVE-2021-41160
Debian:12freerdp22.4.1+dfsg1-1DEBIAN-CVE-2021-41160
Rocky Linux:8freerdp2:2.2.0-7.el8_5RLSA-2021:4622
Ubuntu:22.04:LTSfreerdp22.3.0+dfsg1-2ubuntu2UBUNTU-CVE-2021-41160

Affected products (as reported)

VendorProductVersions
FreeRDP FreeRDP < 2.4.1

Weakness: CWE-787 · Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N

References