Vulnerability · Published Oct 21, 2021 · Assigned by GitHub_M
CVE-2021-41159Improper client input validation for FreeRDP gateway connections allows to overwrite memory
Medium 5.8
In plain English
A medium-severity out-of-bounds write in FreeRDP from FreeRDP. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FreeRDP is a free implementation of the Remote Desktop Protocol (RDP), released under the Apache license. All FreeRDP clients prior to version 2.4.1 using gateway connections (`/gt:rpc`) fail to validate input data. A malicious gateway might allow client memory to be written out of bounds. This issue has been resolved in version 2.4.1. If you are unable to update then use `/gt:http` rather than /gt:rdp connections if possible or use a direct connection without a gateway.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | freerdp | 2:2.2.0-7.el8_5 | ALSA-2021:4622 |
| AlmaLinux:8 | freerdp-devel | 2:2.2.0-7.el8_5 | ALSA-2021:4622 |
| AlmaLinux:8 | freerdp-libs | 2:2.2.0-7.el8_5 | ALSA-2021:4622 |
| AlmaLinux:8 | libwinpr | 2:2.2.0-7.el8_5 | ALSA-2021:4622 |
| AlmaLinux:8 | libwinpr-devel | 2:2.2.0-7.el8_5 | ALSA-2021:4622 |
| Alpine:v3.20 | freerdp | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.21 | freerdp | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.22 | freerdp | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.23 | freerdp | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.24 | freerdp | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.22 | freerdp2 | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.23 | freerdp2 | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Alpine:v3.24 | freerdp2 | 2.4.1-r0 | ALPINE-CVE-2021-41159 |
| Debian:12 | freerdp2 | 2.4.1+dfsg1-1 | DEBIAN-CVE-2021-41159 |
| Rocky Linux:8 | freerdp | 2:2.2.0-7.el8_5 | RLSA-2021:4622 |
| Ubuntu:22.04:LTS | freerdp2 | 2.3.0+dfsg1-2ubuntu2 | UBUNTU-CVE-2021-41159 |
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N
References
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-vh34-m9h7-95xq
- FEDORA-2021-2c25f03d0b vendor-advisory
- GLSA-202210-24 vendor-advisory