Vulnerability · Published Oct 12, 2021 · Assigned by GitHub_M

CVE-2021-41136Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma

Low 3.7

In plain English

A low-severity security flaw in puma from puma. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)1.2%top 31.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12puma5.5.2-1DEBIAN-CVE-2021-41136
Debian:13puma5.5.2-1DEBIAN-CVE-2021-41136
Debian:14puma5.5.2-1DEBIAN-CVE-2021-41136
Rocky Linux:8libdb0:5.3.28-42.el8_4RLSA-2022:5498
RubyGemspuma5.5.1GHSA-48w2-rm65-62xx
RubyGemspuma4.3.9GHSA-48w2-rm65-62xx
Ubuntu:22.04:LTSpuma5.5.2-2ubuntu2UBUNTU-CVE-2021-41136

Affected products (as reported)

VendorProductVersions
puma puma >= 5.0.0, < 5.5.1< 4.3.9

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N

References