Vulnerability · Published Oct 5, 2021 · Assigned by GitHub_M

CVE-2021-41122Bounds check missing for decimal args in Vyper

Medium 4.3

In plain English

A medium-severity security flaw in vyper from vyperlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.8%top 43.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvyper0.3.0GHSA-c7pr-343r-5c46
PyPIvyper0.3.0PYSEC-2021-366

Affected products (as reported)

VendorProductVersions
vyperlang vyper < 0.3.0

Weakness: CWE-682 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

References