Vulnerability · Published Oct 6, 2021 · Assigned by GitHub_M

CVE-2021-41121Memory corruption in Vyper

High 7.5

In plain English

A high-severity memory corruption in vyper from vyperlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.1%top 34.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvyper0.3.0GHSA-xv8x-pr4h-73jv
PyPIvyper0.3.0PYSEC-2021-365

Affected products (as reported)

VendorProductVersions
vyperlang vyper < 0.3.0

Weakness: CWE-119 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References