Vulnerability · Published Oct 4, 2021 · Assigned by GitHub_M

CVE-2021-41103Insufficiently restricted permissions on plugin directories

Medium 5.9

In plain English

A medium-severity path traversal in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)5.9Medium
Exploit odds (30 days)0.5%top 55.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20containerd1.5.7-r0ALPINE-CVE-2021-41103
Alpine:v3.21containerd1.5.7-r0ALPINE-CVE-2021-41103
Alpine:v3.22containerd1.5.7-r0ALPINE-CVE-2021-41103
Alpine:v3.23containerd1.5.7-r0ALPINE-CVE-2021-41103
Alpine:v3.24containerd1.5.7-r0ALPINE-CVE-2021-41103
Debian:12containerd1.5.7~ds1-1DEBIAN-CVE-2021-41103
Debian:13containerd1.5.7~ds1-1DEBIAN-CVE-2021-41103
Debian:14containerd1.5.7~ds1-1DEBIAN-CVE-2021-41103
Gogithub.com/containerd/containerd1.5.7GHSA-c2h3-6mxw-7mvq
Gogithub.com/containerd/containerd1.4.11GHSA-c2h3-6mxw-7mvq
Gogithub.com/containerd/containerd1.4.11, 1.5.7GO-2022-0938
Ubuntu:22.04:LTScontainerd1.5.5-0ubuntu3UBUNTU-CVE-2021-41103

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.4.11>= 1.5.0, < 1.5.7

Weakness: CWE-22 · Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References