Vulnerability · Published Nov 24, 2021 · Assigned by apache

CVE-2021-40369XSS vulnerability on Denounce plugin

Medium 6.1

In plain English

A medium-severity security flaw in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.4% (higher than 89% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.1Medium
Exploit odds (30 days)3.4%top 11.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.jspwiki:jspwiki-main2.11.0GHSA-cfqj-9g2g-w7q6

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache JSPWiki Apache JSPWiki – through 2.11.0.M8

References