Vulnerability · Published Jan 4, 2022 · Assigned by apache

CVE-2021-40111Apache James IMAP parsing Denial Of Service

Medium 6.5

In plain English

A medium-severity security flaw in Apache James from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)2.2%top 17.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.james:james-server3.6.1GHSA-fqgw-6qj5-8hmp

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache James Apache James – through 3.6.0

References