Vulnerability · Published Jan 4, 2022 · Assigned by apache

CVE-2021-40110Apache James IMAP vulnerable to a ReDoS

High 7.5

In plain English

A high-severity security flaw in Apache James from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.0% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)3.0%top 12.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.james:james-server3.6.1GHSA-r58x-wjg8-63m9

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache James Apache James – through 3.6.0

References