Vulnerability · Published Aug 24, 2022 · Assigned by redhat

CVE-2021-3999

High 7.8

In plain English

A high-severity security flaw in glibc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.8%top 43.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A flaw was found in glibc. An off-by-one buffer overflow and underflow in getcwd() may lead to memory corruption when the size of the buffer is exactly 1. A local attacker who can control the input buffer and size passed to getcwd() in a setuid program could use this flaw to potentially execute arbitrary code and escalate their privileges on the system.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8compat-libpthread-nonshared2.28-164.el8_5.3ALSA-2022:0896
AlmaLinux:8glibc-benchtests2.28-164.el8_5.3ALSA-2022:0896
AlmaLinux:8glibc-nss-devel2.28-164.el8_5.3ALSA-2022:0896
AlmaLinux:8glibc-static2.28-164.el8_5.3ALSA-2022:0896
AlmaLinux:8glibc-utils2.28-164.el8_5.3ALSA-2022:0896
AlmaLinux:8nss_hesiod2.28-164.el8_5.3ALSA-2022:0896
Debian:12glibc2.33-4DEBIAN-CVE-2021-3999
Debian:13glibc2.33-4DEBIAN-CVE-2021-3999
Debian:14glibc2.33-4DEBIAN-CVE-2021-3999
Rocky Linux:8glibc0:2.28-164.el8_5.3RLSA-2022:0896

Affected products (as reported)

VendorProductVersions
n/a glibc Fixed in glibc v2.31 and above.

Weakness: CWE-193 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References