Vulnerability · Published Sep 16, 2021 · Assigned by GitHub_M
CVE-2021-39214Lacking Protection against HTTP Request Smuggling in mitmproxy
High 8.1
In plain English
A high-severity security flaw in mitmproxy from mitmproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.2 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While a smuggled request is still captured as part of another request's body, it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless one uses mitmproxy to protect an HTTP/1 service, no action is required. The vulnerability has been fixed in mitmproxy 7.0.3 and above.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | mitmproxy | 7.0.3-r0 | ALPINE-CVE-2021-39214 |
| Alpine:v3.22 | mitmproxy | 7.0.3-r0 | ALPINE-CVE-2021-39214 |
| Alpine:v3.23 | mitmproxy | 7.0.3-r0 | ALPINE-CVE-2021-39214 |
| Alpine:v3.24 | mitmproxy | 7.0.3-r0 | ALPINE-CVE-2021-39214 |
| Debian:12 | mitmproxy | 8.1.1-1 | DEBIAN-CVE-2021-39214 |
| Debian:14 | mitmproxy | 8.1.1-1 | DEBIAN-CVE-2021-39214 |
| PyPI | mitmproxy | 7.0.3 | PYSEC-2021-328 |
| PyPI | mitmproxy | 7.0.3 | GHSA-22gh-3r9q-xf38 |
| Ubuntu:22.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2021-39214 |
| Ubuntu:24.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2021-39214 |
| Ubuntu:25.10 | mitmproxy | no fix listed | UBUNTU-CVE-2021-39214 |
| Ubuntu:26.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2021-39214 |
| Ubuntu:26.10 | mitmproxy | no fix listed | UBUNTU-CVE-2021-39214 |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-22gh-3r9q-xf38 x_refsource_CONFIRM