Vulnerability · Published Aug 27, 2021 · Assigned by GitHub_M
CVE-2021-39171Unlimited transforms allowed for signed nodes
Medium 5.3
In plain English
A medium-severity uncontrolled resource consumption in passport-saml from node-saml. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | passport-saml | 3.1.0 | GHSA-5379-r78w-42h2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| node-saml | passport-saml | < 3.1.0 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/node-saml/passport-saml/security/advisories/GHSA-5379-r78w-42h2 x_refsource_CONFIRM
- https://github.com/node-saml/passport-saml/pull/595 x_refsource_MISC