Vulnerability · Published Aug 26, 2021 · Assigned by GitHub_M
CVE-2021-39168TimelockController vulnerability in OpenZeppelin Contracts
Critical 10.0
In plain English
A critical-severity privilege mismanagement in openzeppelin-contracts-upgradeable from OpenZeppelin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenZepplin is a library for smart contract development. In affected versions a vulnerability in TimelockController allowed an actor with the executor role to escalate privileges. Further details about the vulnerability will be disclosed at a later date. As a workaround revoke the executor role from accounts not strictly under the team's control. We recommend revoking all executors that are not also proposers. When applying this mitigation, ensure there is at least one proposer and executor remaining.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openzeppelin/contracts-upgradeable | 4.3.1 | GHSA-vrw4-w73r-6mm8 |
| npm | @openzeppelin/contracts-upgradeable | 3.4.2 | GHSA-vrw4-w73r-6mm8 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenZeppelin | openzeppelin-contracts-upgradeable | >=4.0.0, < 4.3.1>=3.3.0, < 3.4.2>= 3.3.0-solc-0.7, < 3.4.2-solc-0.7 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/OpenZeppelin/openzeppelin-contracts-upgradeable/security/advisories/GHSA-vrw4-w73r-6mm8 x_refsource_CONFIRM
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/cec4f2ef57495d8b1742d62846da212515d99dd5 x_refsource_MISC
- https://github.com/OpenZeppelin/openzeppelin-contracts/blob/master/CHANGELOG.md#431 x_refsource_MISC