Vulnerability · Published Aug 31, 2021 · Assigned by GitHub_M

CVE-2021-39134UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

High 8.2

In plain English

A high-severity security flaw in arborist from npm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.6%top 51.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

`@npmcli/arborist`, the library that calculates dependency trees and manages the `node_modules` folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in `package.json` manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist within the same level in the `node_modules` hierarchy. However, on case-insensitive file systems (such as macOS and Windows), this is not the case. Combined with a symlink dependency such as `file:/some/path`, this allowed an attacker to create a situation in which arbitrary contents could be written to any location on the filesystem. For example, a package `pwn-a` could define a dependency in their `package.json` file such as `"foo": "file:/some/path"`. Another package, `pwn-b` could define a dependency such as `FOO: "file:foo.tgz"`. On case-insensitive file systems, if `pwn-a` was installed, and then `pwn-b` was installed afterwards, the contents of `foo.tgz` would be written to `/some/path`, and any existing contents of `/some/path` would be removed. Anyone using npm v7.20.6 or earlier on a case-insensitive filesystem is potentially affected. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20nodejs14.17.6-r0ALPINE-CVE-2021-39134
Alpine:v3.21nodejs14.17.6-r0ALPINE-CVE-2021-39134
Alpine:v3.22nodejs14.17.6-r0ALPINE-CVE-2021-39134
Alpine:v3.23nodejs14.17.6-r0ALPINE-CVE-2021-39134
Alpine:v3.24nodejs14.17.6-r0ALPINE-CVE-2021-39134
Debian:12npm7.24.0+ds-2DEBIAN-CVE-2021-39134
Debian:13npm7.24.0+ds-2DEBIAN-CVE-2021-39134
Debian:14npm7.24.0+ds-2DEBIAN-CVE-2021-39134
npm@npmcli/arborist2.8.2GHSA-2h3h-q99f-3fhc

Affected products (as reported)

VendorProductVersions
npm arborist < 2.8.2

Weakness: CWE-61 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

References