Vulnerability · Published Aug 17, 2021 · Assigned by GitHub_M

CVE-2021-39131Improper Handling of Unexpected Data Type in ced

High 7.5

In plain English

A high-severity security flaw in ced from sonicdoe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.9%top 20.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

ced detects character encoding using Google’s compact_enc_det library. In ced v0.1.0, passing data types other than `Buffer` causes the Node.js process to crash. The problem has been patched in ced v1.0.0. As a workaround, before passing an argument to ced, verify it’s a `Buffer` using `Buffer.isBuffer(obj)`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmced1.0.0GHSA-27wq-qx3q-fxm9

Affected products (as reported)

VendorProductVersions
sonicdoe ced < 1.0.0

Weakness: CWE-241 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References