Vulnerability · Published Oct 14, 2021 · Assigned by @huntrdev

CVE-2021-3882Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in ledgersmb/ledgersmb

Medium 5.9

In plain English

A medium-severity security flaw in ledgersmb/ledgersmb from ledgersmb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)5.9Medium
Exploit odds (30 days)1.1%top 33.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSledgersmb1.6.33+ds-1ubuntu0.1USN-7647-1
Ubuntu:22.04:LTSledgersmb1.6.33+ds-1ubuntu0.1UBUNTU-CVE-2021-3882
Ubuntu:24.04:LTSledgersmb1.6.33+ds-2.1ubuntu0.1USN-7647-1
Ubuntu:24.04:LTSledgersmb1.6.33+ds-2.1ubuntu0.1UBUNTU-CVE-2021-3882

Affected products (as reported)

VendorProductVersions
ledgersmb ledgersmb/ledgersmb 1.8.0 – before unspecifiedunspecified – through 1.8.21

Weakness: CWE-614 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N

References