Vulnerability · Published Oct 14, 2021 · Assigned by Wordfence
CVE-2021-38345Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification
High 7.1
In plain English
A high-severity cross-site scripting in Brizy - Page Builder from Brizy.io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities).
Official description
The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Brizy.io | Brizy - Page Builder | 2.3.11 – through 2.3.111.0.127 – before 1.0.127*1.0.125 – through 1.0.125 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L