Vulnerability · Published Aug 11, 2021 · Assigned by GitHub_M

CVE-2021-37627Privilege escalation via form generator

High 8.0

In plain English

A high-severity privilege mismanagement in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.0%top 36.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcontao/contao4.4.56GHSA-hq5m-mqmx-fw6m
Packagistcontao/contao4.9.18GHSA-hq5m-mqmx-fw6m
Packagistcontao/contao4.11.7GHSA-hq5m-mqmx-fw6m
Packagistcontao/core-bundle4.4.56GHSA-hq5m-mqmx-fw6m
Packagistcontao/core-bundle4.9.18GHSA-hq5m-mqmx-fw6m
Packagistcontao/core-bundle4.11.7GHSA-hq5m-mqmx-fw6m

Affected products (as reported)

VendorProductVersions
contao contao < 4.4.56>= 4.5.0, < 4.9.18>= 4.10.0, < 4.11.7

Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

References