Vulnerability · Published Aug 9, 2021 · Assigned by GitHub_M

CVE-2021-37618Out-of-bounds read in Exiv2::Jp2Image::printStructure

Medium 4.7

In plain English

A medium-severity out-of-bounds read in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.7Medium
Exploit odds (30 days)1.0%top 37.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.4 and earlier. The out-of-bounds read is triggered when Exiv2 is used to print the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when printing the image ICC profile, which is a less frequently used Exiv2 operation that requires an extra command line option (`-p C`). The bug is fixed in version v0.27.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8compat-exiv2-0260.26-6.el8ALSA-2021:4319
AlmaLinux:8exiv20.27.4-5.el8ALSA-2021:4173
AlmaLinux:8exiv2-devel0.27.4-5.el8ALSA-2021:4173
AlmaLinux:8exiv2-doc0.27.4-5.el8ALSA-2021:4173
AlmaLinux:8exiv2-libs0.27.4-5.el8ALSA-2021:4173
Alpine:v3.20exiv20.27.5-r0ALPINE-CVE-2021-37618
Alpine:v3.21exiv20.27.5-r0ALPINE-CVE-2021-37618
Alpine:v3.22exiv20.27.5-r0ALPINE-CVE-2021-37618
Alpine:v3.23exiv20.27.5-r0ALPINE-CVE-2021-37618
Alpine:v3.24exiv20.27.5-r0ALPINE-CVE-2021-37618
Debian:12exiv20.27.5-1DEBIAN-CVE-2021-37618
Debian:13exiv20.27.5-1DEBIAN-CVE-2021-37618
Debian:14exiv20.27.5-1DEBIAN-CVE-2021-37618
Rocky Linux:8compat-exiv2-0260:0.26-6.el8RLSA-2021:4319
Rocky Linux:8exiv20:0.27.4-5.el8RLSA-2021:4173
Ubuntu:22.04:LTSexiv20.27.3-3ubuntu4UBUNTU-CVE-2021-37618

Affected products (as reported)

VendorProductVersions
Exiv2 exiv2 <= 0.27.4

Weakness: CWE-125 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H

References