Vulnerability · Published Aug 24, 2021 · Assigned by openssl

CVE-2021-3711SM2 Decryption Buffer Overflow

Critical 9.8

In plain English

A critical-severity security flaw in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 87.8% (higher than 99.8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)87.8%top 0.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20openssl1.1.1l-r0ALPINE-CVE-2021-3711
Alpine:v3.21openssl1.1.1l-r0ALPINE-CVE-2021-3711
Alpine:v3.22openssl1.1.1l-r0ALPINE-CVE-2021-3711
Alpine:v3.23openssl1.1.1l-r0ALPINE-CVE-2021-3711
Alpine:v3.24openssl1.1.1l-r0ALPINE-CVE-2021-3711
Debian:12openssl1.1.1l-1DEBIAN-CVE-2021-3711
Debian:13openssl1.1.1l-1DEBIAN-CVE-2021-3711
Debian:14openssl1.1.1l-1DEBIAN-CVE-2021-3711
Ubuntu:22.04:LTSopenssl1.1.1l-1ubuntu1UBUNTU-CVE-2021-3711

Affected products (as reported)

VendorProductVersions
OpenSSL OpenSSL Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k)

References