Vulnerability · Published Feb 4, 2022 · Assigned by apache
CVE-2021-36152Insecure TrustManager used in LDAP connections
Critical 9.8
In plain English
A critical-severity security flaw in Apache Gobblin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)1.3%top 29.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.gobblin:gobblin-core | 0.16.0 | GHSA-q5rx-8c2h-5q7j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Gobblin | Apache Gobblin – through 0.15.0 |
References
- https://lists.apache.org/thread/3bxf7rbf4zh95r78jtgth6gwhr5fyl2j x_refsource_MISC