Vulnerability · Published Mar 25, 2021 · Assigned by openssl

CVE-2021-3449NULL pointer deref in signature_algorithms processing

Medium 5.9

In plain English

A medium-severity security flaw in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 63.5% (higher than 99.2% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.9Medium
Exploit odds (30 days)63.5%top 0.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a denial of service attack. A server is only vulnerable if it has TLSv1.2 and renegotiation enabled (which is the default configuration). OpenSSL TLS clients are not impacted by this issue. All OpenSSL 1.1.1 versions are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20openssl1.1.1k-r0ALPINE-CVE-2021-3449
Alpine:v3.21openssl1.1.1k-r0ALPINE-CVE-2021-3449
Alpine:v3.22openssl1.1.1k-r0ALPINE-CVE-2021-3449
Alpine:v3.23openssl1.1.1k-r0ALPINE-CVE-2021-3449
Alpine:v3.24openssl1.1.1k-r0ALPINE-CVE-2021-3449
Alpine:v3.20synapse1.30.1-r0ALPINE-CVE-2021-3449
Alpine:v3.21synapse1.30.1-r0ALPINE-CVE-2021-3449
Alpine:v3.22synapse1.30.1-r0ALPINE-CVE-2021-3449
Alpine:v3.23synapse1.30.1-r0ALPINE-CVE-2021-3449
Alpine:v3.24synapse1.30.1-r0ALPINE-CVE-2021-3449
Debian:12openssl1.1.1k-1DEBIAN-CVE-2021-3449
Debian:13openssl1.1.1k-1DEBIAN-CVE-2021-3449
Debian:14openssl1.1.1k-1DEBIAN-CVE-2021-3449
Rocky Linux:8openssl1:1.1.1g-15.el8_3RLSA-2021:1024

Affected products (as reported)

VendorProductVersions
OpenSSL OpenSSL Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j)

References