Vulnerability · Published Feb 20, 2023 · Assigned by GitHub_M
CVE-2021-32852countly-server vulnerable to Cross-site Scripting
Medium 5.4
In plain English
A medium-severity cross-site scripting in countly-server from Countly. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities).
Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.9%top 39.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Countly, a product analytics solution, is vulnerable to cross-site scripting prior to version 21.11 of the community edition. The victim must follow a malicious link or be redirected there from malicious web site. The attacker must have an account or be able to create one. This issue is patched in version 21.11.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Countly | countly-server | 21.11 – before 21.11 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://securitylab.github.com/advisories/GHSL-2021-104-countly-server/
- https://github.com/Countly/countly-server/releases/tag/v21.11
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/views/reset.html#L95
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/app.js#L1112