Vulnerability · Published Feb 20, 2023 · Assigned by GitHub_M

CVE-2021-32850jQuery MiniColors vulnerable to Cross-site Scripting

Medium 6.1

In plain English

A medium-severity cross-site scripting in @claviska/jquery-minicolors from npm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.8%top 43.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

jQuery MiniColors is a color picker built on jQuery. Prior to version 2.3.6, jQuery MiniColors is prone to cross-site scripting when handling untrusted color names. This issue is patched in version 2.3.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jquery-minicolors2.3.5+dfsg-4DEBIAN-CVE-2021-32850
Debian:13jquery-minicolors2.3.5+dfsg-4DEBIAN-CVE-2021-32850
Debian:14jquery-minicolors2.3.5+dfsg-4DEBIAN-CVE-2021-32850
Ubuntu:22.04:LTSjquery-minicolorsno fix listedUBUNTU-CVE-2021-32850
Ubuntu:24.04:LTSjquery-minicolorsno fix listedUBUNTU-CVE-2021-32850
Ubuntu:25.10jquery-minicolorsno fix listedUBUNTU-CVE-2021-32850
Ubuntu:26.04:LTSjquery-minicolorsno fix listedUBUNTU-CVE-2021-32850
Ubuntu:26.10jquery-minicolorsno fix listedUBUNTU-CVE-2021-32850
npm@claviska/jquery-minicolors2.3.6GHSA-crh5-vv2v-c82q

Affected products (as reported)

VendorProductVersions
npm @claviska/jquery-minicolors 2.3.6 – before 2.3.6

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References