Vulnerability · Published May 14, 2021 · Assigned by GitHub_M
CVE-2021-32819Remote code execution in squirrelly
High 8.0
In plain English
A high-severity information exposure in squirrelly from squirrellyjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 58.3% (higher than 99.1% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Squirrelly is a template engine implemented in JavaScript that works out of the box with ExpressJS. Squirrelly mixes pure template data with engine configuration options through the Express render API. By overwriting internal configuration options remote code execution may be triggered in downstream applications. This issue is fixed in version 9.0.0. For complete details refer to the referenced GHSL-2021-023.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | squirrelly | 9.0.0 | GHSA-q8j6-pwqx-pm96 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| squirrellyjs | squirrelly | 9.0.0 – before 9.0.0 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N