Vulnerability · Published Aug 12, 2021 · Assigned by GitHub_M

CVE-2021-32809Arbitrary HTML injection vulnerability in ckeditor

Medium 4.6

In plain English

A medium-severity code injection in ckeditor4 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.6Medium
Exploit odds (30 days)1.2%top 32.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ckeditor4.16.2+dfsg-1DEBIAN-CVE-2021-32809
npmckeditor44.16.2GHSA-7889-rm5j-hpgg

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor4 >= 4.5.2, < 4.16.2

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

References