Vulnerability · Published Aug 12, 2021 · Assigned by GitHub_M

CVE-2021-32808Cross-site scripting in ckeditor via abuse of undo functionality

High 7.6

In plain English

A high-severity cross-site scripting in ckeditor4 from ckeditor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.6High
Exploit odds (30 days)1.2%top 31.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ckeditor4.16.2+dfsg-1DEBIAN-CVE-2021-32808
Ubuntu:22.04:LTSckeditor4.16.2+dfsg-1UBUNTU-CVE-2021-32808
npmckeditor44.16.2GHSA-6226-h7ff-ch6c

Affected products (as reported)

VendorProductVersions
ckeditor ckeditor4 >= 4.13.0, < 4.16.2

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N

References