Vulnerability · Published Oct 4, 2021 · Assigned by GitHub_M

CVE-2021-32762Integer overflow that can lead to heap overflow in redis-cli, redis-sentinel on some platforms

High 7.5

In plain English

A high-severity integer overflow in redis from redis. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.6%top 14.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Redis is an open source, in-memory database that persists on disk. The redis-cli command line tool and redis-sentinel service may be vulnerable to integer overflow when parsing specially crafted large multi-bulk network replies. This is a result of a vulnerability in the underlying hiredis library which does not perform an overflow check before calling the calloc() heap allocation function. This issue only impacts systems with heap allocators that do not perform their own overflow checks. Most modern systems do and are therefore not likely to be affected. Furthermore, by default redis-sentinel uses the jemalloc allocator which is also not vulnerable. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20redis6.2.6-r0ALPINE-CVE-2021-32762
Alpine:v3.21redis6.2.6-r0ALPINE-CVE-2021-32762
Alpine:v3.22redis6.2.6-r0ALPINE-CVE-2021-32762
Alpine:v3.23redis6.2.6-r0ALPINE-CVE-2021-32762
Alpine:v3.24redis6.2.6-r0ALPINE-CVE-2021-32762
Debian:12redis5:6.0.16-1DEBIAN-CVE-2021-32762
Debian:13redis5:6.0.16-1DEBIAN-CVE-2021-32762
Debian:14redis5:6.0.16-1DEBIAN-CVE-2021-32762

Affected products (as reported)

VendorProductVersions
redis redis < 5.0.14>= 6.0.0, < 6.0.16>= 6.2.0, < 6.2.6

Weakness: CWE-190, CWE-680 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References