Vulnerability · Published Jul 19, 2021 · Assigned by GitHub_M
CVE-2021-32760Archive package allows chmod of file outside of unpack target directory
Medium 5.0
In plain English
A medium-severity security flaw in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
containerd is a container runtime. A bug was found in containerd versions prior to 1.4.8 and 1.5.4 where pulling and extracting a specially-crafted container image can result in Unix file permission changes for existing files in the host’s filesystem. Changes to file permissions can deny access to the expected owner of the file, widen access to others, or set extended bits like setuid, setgid, and sticky. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. This bug has been fixed in containerd 1.5.4 and 1.4.8. As a workaround, ensure that users only pull images from trusted sources. Linux security modules (LSMs) like SELinux and AppArmor can limit the files potentially affected by this bug through policies and profiles that prevent containerd from interacting with specific files.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | containerd | 1.5.4-r0 | ALPINE-CVE-2021-32760 |
| Alpine:v3.21 | containerd | 1.5.4-r0 | ALPINE-CVE-2021-32760 |
| Alpine:v3.22 | containerd | 1.5.4-r0 | ALPINE-CVE-2021-32760 |
| Alpine:v3.23 | containerd | 1.5.4-r0 | ALPINE-CVE-2021-32760 |
| Alpine:v3.24 | containerd | 1.5.4-r0 | ALPINE-CVE-2021-32760 |
| Debian:12 | containerd | 1.4.5~ds1-2 | DEBIAN-CVE-2021-32760 |
| Debian:13 | containerd | 1.4.5~ds1-2 | DEBIAN-CVE-2021-32760 |
| Debian:14 | containerd | 1.4.5~ds1-2 | DEBIAN-CVE-2021-32760 |
| Go | github.com/containerd/containerd | 1.4.8, 1.5.4 | GO-2022-0921 |
| Go | github.com/containerd/containerd | 1.5.4 | GHSA-c72p-9xmj-rx3w |
| Go | github.com/containerd/containerd | 1.4.8 | GHSA-c72p-9xmj-rx3w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| containerd | containerd | <= 1.4.7>= 1.5.0, <= 1.5.3 |
Weakness: CWE-668 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L