Vulnerability · Published Jul 1, 2021 · Assigned by GitHub_M

CVE-2021-32729A user without PR can reset user authentication failures information

Low 2.0

In plain English

A low-severity security flaw in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.0Low
Exploit odds (30 days)0.5%top 57.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A vulnerability exists in versions prior to 12.6.88, 12.10.4, and 13.0. The script service method used to reset the authentication failures record can be executed by any user with Script rights and does not require Programming rights. An attacher with script rights who is able to reset the authentication failure record might perform a brute force attack, since they would be able to virtually deactivate the mechanism introduced to mitigate those attacks. The problem has been patched in version 12.6.8, 12.10.4 and 13.0. There are no workarounds aside from upgrading.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-security-authentication-script12.6.8GHSA-m738-3rc4-5xv3
Mavenorg.xwiki.platform:xwiki-platform-security-authentication-script12.10.4GHSA-m738-3rc4-5xv3

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform > 11.6RC1, < 12.6.8>= 12.10.0, < 12.10.4

Weakness: CWE-693 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N

References