Vulnerability · Published Jul 7, 2021 · Assigned by GitHub_M
CVE-2021-32714Integer Overflow in Chunked Transfer-Encoding
Medium 5.9
In plain English
A medium-severity integer overflow in hyper from hyperium. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rust-hyper | 0.14.19-1 | DEBIAN-CVE-2021-32714 |
| Debian:13 | rust-hyper | 0.14.19-1 | DEBIAN-CVE-2021-32714 |
| Debian:14 | rust-hyper | 0.14.19-1 | DEBIAN-CVE-2021-32714 |
Affected products (as reported)
Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/hyperium/hyper/security/advisories/GHSA-5h46-h7hh-c6x9 x_refsource_CONFIRM