Vulnerability · Published Jul 12, 2021 · Assigned by GitHub_M
CVE-2021-32678Ratelimit not applied on OCS API responses
Low 3.7
In plain English
A low-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities).
Official description
Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 19.0.13>= 20.0.0, < 20.0.11>= 21.0.0, < 21.0.3 |
Weakness: CWE-799 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-48rx-3gmf-g74j x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/27329 x_refsource_MISC
- https://hackerone.com/reports/1214158 x_refsource_MISC
- FEDORA-2021-9b421b78af vendor-advisory, x_refsource_FEDORA
- FEDORA-2021-6f327296fe vendor-advisory, x_refsource_FEDORA
- GLSA-202208-17 vendor-advisory, x_refsource_GENTOO