Vulnerability · Published Jun 9, 2021 · Assigned by GitHub_M
CVE-2021-32677Cross-Site Request Forgery (CSRF) in FastAPI
High 8.2
In plain English
A high-severity cross-site request forgery in fastapi from tiangolo. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FastAPI is a web framework for building APIs with Python 3.6+ based on standard Python type hints. FastAPI versions lower than 0.65.2 that used cookies for authentication in path operations that received JSON payloads sent by browsers were vulnerable to a Cross-Site Request Forgery (CSRF) attack. In versions lower than 0.65.2, FastAPI would try to read the request payload as JSON even if the content-type header sent was not set to application/json or a compatible JSON media type (e.g. application/geo+json). A request with a content type of text/plain containing JSON data would be accepted and the JSON data would be extracted. Requests with content type text/plain are exempt from CORS preflights, for being considered Simple requests. The browser will execute them right away including cookies, and the text content could be a JSON string that would be parsed and accepted by the FastAPI application. This is fixed in FastAPI 0.65.2. The request data is now parsed as JSON only if the content-type header is application/json or another JSON compatible media type like application/geo+json. It's best to upgrade to the latest FastAPI, but if updating is not possible then a middleware or a dependency that checks the content-type header and aborts the request if it is not application/json or another JSON compatible content type can act as a mitigating workaround.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | fastapi | 0.70.0-1 | DEBIAN-CVE-2021-32677 |
| Debian:13 | fastapi | 0.70.0-1 | DEBIAN-CVE-2021-32677 |
| Debian:14 | fastapi | 0.70.0-1 | DEBIAN-CVE-2021-32677 |
| PyPI | fastapi | 0.65.2 | GHSA-8h2j-cgx8-6xv7 |
| PyPI | fastapi | 0.65.2 | PYSEC-2021-100 |
| Ubuntu:22.04:LTS | fastapi | no fix listed | UBUNTU-CVE-2021-32677 |
Affected products (as reported)
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
References
- https://github.com/tiangolo/fastapi/security/advisories/GHSA-8h2j-cgx8-6xv7 x_refsource_CONFIRM
- https://github.com/tiangolo/fastapi/commit/fa7e3c996edf2d5482fff8f9d890ac2390dede4d x_refsource_MISC
- FEDORA-2021-917e89c036 vendor-advisory, x_refsource_FEDORA