Vulnerability · Published Jun 8, 2021 · Assigned by GitHub_M

CVE-2021-32674Remote Code Execution via traversal in TAL expressions

High 8.8

In plain English

A high-severity path traversal in Zope from zopefoundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.6%top 24.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities. Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Templates through the web. Only sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk. The problem has been fixed in Zope 5.2.1 and 4.6.1. The workaround is the same as for https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36: A site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIzope4.6.1GHSA-5vq5-pg3r-9ph3
PyPIzope5.2.1GHSA-5vq5-pg3r-9ph3
PyPIzope5.2.1GHSA-rpcg-f9q6-2mq6
PyPIzope4.6.1GHSA-rpcg-f9q6-2mq6
PyPIzope4.6.1, 5.2.1PYSEC-2021-104

Affected products (as reported)

VendorProductVersions
zopefoundation Zope >= 5.0.0, < 5.2.1< 4.6.1

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References